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The Fluocell User’s Guide 
I. Introduction 
Fluocell is a software package for the analysis and visualization of fluorescence images for live 
cells, with applications in migration and cancer invasion. The main package contains a 
visualization and quantification tool for fluorescence intensity and FRET ratio images. Optional 
modules of diffusion analysis and polarity analysis can be obtained upon request. This package is 
mainly written in MATLAB. It is being developed by a group of researchers at the University of 
California, San Diego, and the University of Illinois, Urbana-Champaign. As developers, we are 
open for collaboration on using the software or developing additional features. If you find this 
software package of interest or useful for your work, please take the time to cite our work and 
write an email to tell us, since positive feedbacks are important to secure continuous support for 
this software package.  
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II. Download the Source Code and Imaging Data 
 

1. Download the fluocell source code from here: https://github.com/lu6007/fluocell  
2. Download the fluocell dataset from here: 

http://wang.ucsd.edu/~kalu/fluocell_dataset/fluocell_sample.zip , unzip, and the install it 
to a folder named “fluocell_sample/” which is readable and writable by users. The 
relative location of the dataset README file from the fluocell root directory is: 
fluocell_sample/README.txt 

3. The complete workflow of fluocell can be tested by running the test functions test_fluocell 
with the sample dataset.  
 

 
III. Visualize the ECFP/FRET Ratio Images 
Refer to the “Installation and Usage” section for details on how to install fluocell.  
In the main menu of fluocell,  
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1. Select the FRET protocol. Also note the first channel pattern, second channel pattern, time 

frame pattern, intensity, FRET ratio and processing options.  
 
2. Open the image files: File à Open Figure à Navigate to the image files à Be sure to open 

the first channel file among the list of files, and make sure that the “Time Frame Pattern” 
matches the string pattern in the file name. Sample data image files can be found in the 
folder: fluocell_sample\ 10_24_08_Src_fret_pax\. The first channel image file for src pax is 
‘2-11.001’. Note here how the file name patterns including “First Channel Pattern”, “Second 
Channel Pattern”, “Time Frame Pattern”, etc. are defined in the fluocell main window. As 
shown to the right, the CFP/FRET ratio image will be displayed in Figure 1 and the intensity 
image of FRET will be displayed in Figure 2. There are options to subtract background and 
apply median filter.  

 
The intensity and FRET ratio information are needed for processing the ratio image. 
Independently, the intensity images can be adjusted using the colormap editor by clicking the 
Figure 2 menu: Edit à Colormap. The figures can be copied by clicking Alt+Print Screen, or 
Edit à Copy Figure, and pasted to a Microsoft PowerPoint file. 
 

3. Close files and quit the image tool: File à Close à Quit. Note: it is necessary to close the 
processed image using the Fluocell interface cleanly: File à Close Figure instead of closing 
it directly by clicking “x”.   
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IV. Quantification using regions of interest (ROIs).  
1. In the Fluocell Menu, there is a dropdown list that includes four different options. Select 1 – 

ROI Fixed.  
 

2. Batch process: Tool à Batch Update Image à To process images from 1 to 10, set Image 
Index to [1:10] à click ‘OK’ only once.  

 
3. To retrieve data, copy the output variables 
from the MATLAB Workspace to Excel: 
fluocell_data à time, fluocell_data à ratio, 
fluocell_data à channel1 (average intensity of the 
first channel); fluocell_data à channel2 (average 

intensity of the second channel). The fluocell_data.time variable has two columns. The first 
column contains the index number of the image frames. The second column contains the time 
that the image frames were saved, in minutes starting from 12:00 am.  
 

V. Make Movies 
1. Choose Fluocell settings and open a figure by going to File -> Open Figure 

 
2. Save Ratio images by checking the box “Save Processed Image”, and in Tools -> Batch Update 

Image, enter the range of files (e.g. [1:10]), click ok. The processed images have been saved 
as .tiff files in the data folder.  

Note: once the FRET images are saved, the options Intensity and FRET ratio bound will 
become ineffective. The background, ROI and processed image files are saved in a 
subdirectory output/ within the image path. When the user manually changes the index, the 
ratio images will automatically save in the path:  
fluocell_sample\10_24_08_Src_fret_pax\output\0.3–0.8\ (the range is determined by the 
‘FRET Ratio’ setting in the Fluocell interface). The ratio images are convenient for visual 
inspection. To remove and re-define these files, the user needs to manually remove the saved 
files in output/ folder and repeat the image analysis steps. 
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3. Once the images have been saved, run the make_movie function in the MATLAB command 
window. First, modify the function fluocell/app/sample_init_data.m. Replace the root variable 
in line 4 with the location of fluocell_sample/ folder. Then run these commands:  
>> cd ../../../app 
>> data = sample_init_data('src_pax','make_movie'); 
>> make_movie(data); 
The function make_movie() takes pre-existing images (.tiff) and assembles them into movies. 
The movie file “fret.avi” can be found in the “output\” folder within the data folder. Note: this 
feature currently does not work with Intensity and Intensity-DIC protocols.  

 
VI. Visualize the Intensity Modified FLIM Images 
Load the images from the folder “data\fluocell_sample\flim_0505_2014\” 
 

 

  
 
 
 
 
 
 
 
 
 
 
VII. Polarity Analysis 

Tur-11_1
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Rotate the cells to the horizontal position and quantify the polarity of signal. An example using 
the sample data: 
1. Open the Image.  

• Fluocell Menu à Protocol à Intensity, Time Frame Pattern:{‘001’,’%03d’}, select 
“Subtract Background: 1-manual”, and check the box “Apply Median Filter”. Leave the 
rest to default values.  
 

• Open the image files by selecting File -> Open Figure. Navigate to the data folder 
fluocell_sample\PH-Akt-GFP_1\ -> double click the file “AKT-PH-YFP_PDGF52.001”.  

 

 

 

 

 
2. The cell boundary can be detected by selecting: Tools à Adjust Brightness Factor à Show 

Detected Boundary. Choose the Brightness Factor for cell detection. 
Menu à Tool à Adjust Brightness Factor; Brightness Factor = 1.0 (suggested values are 
between 0.7 and 1.3), check the box “Show Detected Boundary”. Change the index value to 
show the boundary. Adjust the Colormap to 0-5000, Edit à Colormap à Color data min = 0 
and Color data max = 5000 (for other data, adjust as needed). *Note: The user may see different 
intensities of color depending on what their default Colormap is in MATLAB. 
 

3. In the file sample_init_data.m, confirm that the root variable in line 4 was updated to the 
location of fluocell_sample/ folder. 
 

4. Run the polarity quantification scripts. First change your current working directory to the 
Fluocell app folder. If you installed Fluocell under the folder “fluocell/”, do this: 

 
>> cd fluocell/app  
>> cell_name = 'akt_1'; 
>> data = sample_init_data('akt_1'); 
>> single_cell_analyzer('akt_1',data); 
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VIII. Tracking Cells and Regions of Interest 
In the “Quantification” submenu, there are four options: (1) 0 – None: no quantification on 
region of interest; (2) 1 – ROI Fixed: quantify the region of interest without tracking cell; (3) 2 – 
ROI Track Cell: quantify the region of interest while tracking the cell.  
 
Note that the option to “Apply Mask” may create a conflict if Fluocell detects another cell in the 
mask and moves the ROIs by mistake. To avoid this conflict, close the figures and re-open the 
figures each time when the “Apply Mask” is checked or unchecked. 
 
For the next example, use the Fluocell GUI to navigate to another example data: tracking_ex/ 
folder. The values and options of brightness factor, number of ROIs etc are chosen in the menu 
“Tools à Adjust Brightness Factor”.   
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To quantify subcellular layers, choose “3 – Quantify Subcell”. In this case, the default 
number of layers is 1, and the user can change it by setting “Number of ROIs” to 1 in the 
“Adjust Brightness Factor” menu.  

  
 
 
 
 

Intensity Ratio_1

1

Intensity Ratio_23

1
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Alternatively, if “Number of ROIs” is set to 3, we have 
 

         
 
 
 
The quantification output can be found in the MATLAB workspace, under the variable 
“fluocell_data”, such as fluocell_data.time, fluocell_data.ratio, fluocell_data.channel1, 
fluocell_data.channel2 etc. The average ratio or intensity values in the ROIs will be calculated and 
updated in fluocell_data. When multiple subcelluar regions are marked, each ROI is the region 
between two curves, numbered from outside in as labeled in the picture above. When z_stack is 
enabled, time-course quantification is disabled, and quantified z_stack values are stored in the 
vector.  
 
 
IX. FA Detection and Subcellular Quantification 
1. Detect cell mask. The following commands will detect a sequence of cell masks and output 

mask files to the subfolder output/ 
>> cd fluocell/app/fa_analysis/ 
>> cell_name = 'src_pax'; 
>> data = sample_init_data(cell_name, 'batch_detect_cell'); 

      >> batch_detect_cell(cell_name, data); 
 

Intensity Ratio_1

1 2 3

Intensity Ratio_23

1 2 3
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2. Detect Focal Adhesions 
>> cell_name = 'src_pax'; 
>> data = sample_init_data(cell_name, 'batch_detect_fa'); 
>> batch_detect_fa(cell_name, data); 
 

 
3. Programs to quantify local FRET ratio and FA intensity.  
>> compute_fa_property(cell_name, data); 
 

 
 
 

Paxillin image overlayed with cell boundary001

Paxillin image overlayed with boundary and FAs001

2 4 6 8 10 12 140.8

1

1.2

1.4

1.6

1.8

2
src_pax FA Layers_5_1

 

 

Ratio in FA
Ratio out FA
Norm. Total FA Intensity
Norm. Total Pax Intensity
Frame Number



 10 

X. Useful Fluocell Functions 
It is required that the image sequence of each cell is located in a separated folder. This function 
can be used to divide multiple position data into different folders: 
batch_sort_file_multiple_position(path, sub_dir). Note: please don’t name a file with any 
space, which may confuse MATLAB programs. 
 

1. Example: 
 
  >> path = 'E:\sof\fluocell_2.1\data\migration\07_01_2010\';   
  >> sub_dir = {'FN5\2_2\', 'FN5\2_3\', 'FN5\2_FBS10\', 'FN10\1\', 'FN20\1\'};  
  >> batch_sort_file_multiple_position (path, sub_dir) 
 

2. The test_fluocell m-file can be run to test the general functionality of Fluocell on your 
computer. The location of data file on your local computer needs to be set for the “root” 
variable in the “sample_init_data()” function.  
 

3. >> test_fluocellDifferent types of regions of interest. By default, fluocell allows the user to 
choose a region of polygonal shape which is supplied by the user. There is an additional option 
to choose a circular region of a fixed diameter. This can be set up in MATLAB by 
 
>> fluocell_data.roi_type = ‘circle with fixed diameter’; 
>> fluocell_data.roi_diameter = 100; 
 
If you want to switch back to a polygonal region, simply remove the roi.mat file from the 
output/ folder and set: 
 
>> fluocell_data.roi_type = ‘any’; 
>> fluocell_data.roi_diameter = 0; 

 
 
XI. Frequently Asked Questions 
 
1. How are the channel patterns and time frame pattern for the images obtained using software 

other than metamorph. 
Answer: The channel patterns and time frame pattern are provided by the user to help Fluocell to 
recognize the donor and acceptor image files. The default values will work for the image files 
obtained from out Nikon microscope via metamorph. For example, the image files have the 
names such as fret11.001, fret11.002, …, fret12.001, fret12.002 etc.  
The first channel pattern: fret11 ; the second channel pattern: fret12; the time frame pattern: 
{‘001’, ‘%03d’}, where the pattern string ‘%03d’ follows the convention in C++ or MATLAB, 
meaning an integer of 3 digits padded by 0. And the string ‘001’ should match the first donor 
image file that you click when opening the image. In another example, the image files have the 
names such as cfp_t1.tiff, cfp_t2.tiff, …, yfp_t1, yfp_t2 etc.. The first channel pattern: cfp; the 
second channel pattern: yfp; the time frame pattern:{‘t01’, ‘t%d’}, where ‘t%d’ means the letter 
‘t’ followed by an integer. 
 
2. The first images opened correctly, but Fluocell cannot navigate through the time sequence.  
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Answer: The Fluocell software uses the “time frame pattern” submitted by the user to recognize 
file names and navigate through the time frame. For example, if the first image file has the 
pattern filename_t1.TIF, the software will replace ‘t1’ with ‘t2’, ‘t3’, ‘t4’ etc. But, if thr image 
has the file name pattern fret18_t1.TIF, Fluocell will process the next file in the time sequence as 
fret28_t2.TIF by replacing the ‘t1’ in two places in the file name. In order to fix this problem, the 
file name pattern needs to be defined as {‘_t1’, ‘_t%d’}, so that Fluocell can correctly replace the 
unique pattern ‘_t1’ with ‘_t2’, ‘_t3’, ‘_t4’ etc. 
 
Note: Moving the Fluocell folder between operating systems may cause problems to arise. If 
Fluocell needs to be run on multiple systems, it is recommended that each system download its 
own copy of the Fluocell program. 
 
 
XII. Installation and Usage 
Download and install Fluocell either in the folder C:/Program Files/ or a local user folder.  
 
Installation check list (3 steps): 
1. Connect MATLAB with Fluocell installation. In MATLAB, add Fluocell programs to the 

searching path by clicking Set Path à Add with Subfolder à double click the files to add à 
fluocell/app/ and fluocell/src/ à Save . The resulting pathdef.m file should be saved either to 
its default location (MATLAB/toolbox/local/) or the same directory as “fluocellJava.jar” 
(usually in fluocell/src/gui/java/). After the searching path is properly added, the unit test 
function test_fluocell() should run with no problem.  
 

2. Update Java on your computer. In the folder fluocell/src/gui/java/ , double-click to run the 
“fluocellJava.jar” file. If Java is properly updated, the fluocell menu (below-left) should 
launch.  

 

 
 
3. Connect Fluocell with MATLAB installation. (1) In the fluocell/src/gui/java/ folder, make a 

copy from “win-default.property” (“mac-default.property” on Mac) to “default.property”; (2) 
Open the “default.property” file with a text editor, and after “matlablocation=” enter the path 
to MATLAB executable. If Fluocell is correctly connected with MATLAB installation, a 
MATLAB command window (above-right) should launch after running “fluocellJava.jar”.  
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On Mac computers, a sample 
default.property file is shown at 
right.  
 
 
 
 
 
In Windows, use double 
backslashes(\\) between directories, since a single backslash is the escape key (e.g. 
“matlablocation=C\:\\Program Files\\MATLAB\\2013a\\bin\\matlab.exe”). 
 
 
To Open Fluocell: 

• On Windows/Mac 
o Double click “fluocellJava.jar”. The fluocell menu and a new session of MATLAB 

should launch. If the fluocell menu does not launch, please update your java 
installation. If the MATLAB window does not launch, then the installation of 
MATLAB needs to be input into fluocell by editing the “default.property” file.  

o For future convenient usage, please make a shortcut of the executable file 
“fluocellJava.jar” and move it to the desktop. Do not make a copy of 
“fluocellJava.jar” since the java file needs to be in the same folder as the 
“default.property” file.  

  
• On Linux 

o In the terminal, navigate to the directory containing “fluocellJava.jar.” 
o Enter “sudo java –jar fluocellJava.jar.” A window should appear, and a new 

session of MATLAB should launch. 
 
 
 
XIII. Updates 
1. Version fluocell-6.0 
 
 


